PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
UPNPListePériphérique (Fonction)
En anglais : UPNPListDevice
Liste les périphériques UPnP disponibles sur le réseau.
Exemple
WINDEVWindows
tabPériphériques est un tableau de upnpPériphérique
tabPériphériques = UPNPListePériphérique("upnp:rootdevice", 51300)
SI ErreurDétectée ALORS
Info(ErreurInfo(errComplet))
SINON
InitListePériphérique()
FIN
iPhone/iPad
tabPériphériques est un tableau de upnpPériphérique
sMaChaîne est une chaîne ANSI = "upnp:rootdevice"
tabPériphériques = UPNPListePériphérique(sMaChaîne, 51300)
SI ErreurDétectée ALORS
Info(ErreurInfo(errComplet))
SINON
InitListePériphérique()
FIN
Syntaxe
<Résultat> = UPNPListePériphérique(<Type> , <Port> [, <Adresse> [, <Délai>]])
<Résultat> : Tableau de variables de type upnpPéripérique
Nom du tableau de variables de type upnpPériphérique contenant la liste des périphériques trouvés sur le réseau.
<Type> : Chaîne de caractères (avec guillemets)
Type des périphériques à lister.
<Port> : Entier
Numéro du port utilisé pour la recherche.
<Adresse> : Chaîne de caractères avec guillemets optionnelle
Adresse sur laquelle la socket de recherche est créée.
<Délai> : Entier optionnel
Temps maximal de recherche (time-out) exprimé en secondes. Ce paramètre peut correspondre à :
  • un entier correspondant au nombre de secondes,
  • une variable de type Durée,
  • Versions 23 et supérieures
    l'indication directe de la durée (par exemple 1 s ou 10 ms).
    Nouveauté 23
    l'indication directe de la durée (par exemple 1 s ou 10 ms).
    l'indication directe de la durée (par exemple 1 s ou 10 ms).
Par défaut, ce paramètre correspond à 5 secondes.
Composantes
WINDEV wd230device.dll
Version minimum requise
  • Version 19
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire