PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
inAppListeInfoProduit (Fonction)
En anglais : inAppListProductInfo
Récupère à partir du store les informations sur les produits "In-App" associés à l'application.
Exemple
tabIdentifiant est un tableau de chaînes

SI EnModeAndroid() ALORS
tabIdentifiant = ["produit1", "produit2", "produit3", "produit4", "produit inconnu"]
SINON
tabIdentifiant = ["IDProduit1", "IDProduit2", "IDProduit3", ...
"IDProduit4", "IDProduit5", "produit inconnu"]
FIN

SI inAppListeInfoProduit(tabIdentifiant, ListeInfoProduits) ALORS
 ToastAffiche("Demande de la liste des produits envoyée.")
SINON
Erreur("ERREUR : " + ErreurInfo)
FIN
// --------------------
// Procédure ListeInfoProduits
PROCEDURE ListeInfoProduits(bSuccès est un booléen, ...
tabProduits est un tableau de inAppProduit)
SI PAS bSuccès ALORS
Erreur("Erreur : " + ErreurInfo())
RETOUR
FIN

ZoneRépétéeSupprimeTout(ZR_InfoProduit)
POUR i = 1 _A_ tabProduits..Occurrence
ZoneRépétéeAjouteLigne(ZR_InfoProduit, ...
tabProduits[i]..Libellé, tabProduits[i]..Description, ...
tabProduits[i]..Identifiant, tabProduits[i]..Prix)
FIN
// Copie dans le tableau global à la fenêtre
gtabProduit <= tabProduits
Syntaxe
<Résultat> = inAppListeInfoProduit(<Identifiants des produits> , <Nom de la procédure>)
<Résultat> : Booléen
  • Vrai si la demande de récupération des informations produit a été effectuée,
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Identifiants des produits> : Tableau de chaînes de caractères
Identifiants des produits à manipuler. Ces identifiants sont ceux définis lors de la création des produits :
  • iPhone/iPad dans iTunes Connect.
  • Android dans la console développeur Google Play.
Android Il n'est pas possible de demander la récupération d'informations sur plus de 20 produits à la fois. Une erreur fatale sera déclenchée si plus de 20 identifiants sont spécifiés.
Remarque : Si un identifiant ne correspond pas à un produit existant, il est ignoré.
<Nom de la procédure> : Chaîne de caractères (avec ou sans guillemets)
Nom de la procédure WLangage (également nommée "callback") exécutée lors de la réception des informations sur les produits. Cette procédure est de la forme :
PROCEDURE <Nom de la procédure> (<Succès> est un booléen,
<Informations Produits> est un tableau de inAppProduit)

  • <Succès> est un booléen :
    • Vrai si les informations sur les produits ont été récupérées,
    • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo avant tout autre appel à une fonction WLangage (ce qui réinitialiserait l'erreur).
  • <Informations Produits> est un tableau de variables de type inAppProduit contenant les informations sur chacun des produits existants dont l'identifiant a été spécifié. Si l'identifiant ne correspond pas à un produit existant, il est ignoré.
    Si <Succès> = Faux alors le tableau sera vide.
Remarques
  • La demande d'informations est asynchrone afin de ne pas bloquer l'application pendant la récupération des informations sur les produits. Cette opération peut en effet être longue car elle nécessite d'effectuer des requêtes réseau.
  • Android Pour connaître la liste des produits achetés par l'utilisateur et non consommés, utilisez la fonction inAppListeAchat. Pour connaître la liste des produits achetés par l'utilisateur et non consommés et la liste des abonnements actifs, utilisez la fonction inAppListeAchat.
  • Android La fonction inAppListeInfoProduit sera sans effet si elle est exécutée depuis le simulateur ou l'émulateur Android.
  • iPhone/iPad La fonction inAppListeInfoProduit doit être appelée avant tout autre appel de fonctions inAppXXX.
  • Android La fonction inAppListeInfoProduit est disponible uniquement sur les appareils disposant d’une version d’Android supérieure ou égale à la version 2.2 (api level 8). Si la fonction est utilisée avec une version antérieure du système, une erreur fatale sera déclenchée.
    Pour connaître la version du système Android sur laquelle s’exécute l’application, utilisez la fonction SysVersionAndroid.
Composantes
Windows Mobile wp230device.dll
Version minimum requise
  • Version 19
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire