PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Fonctionnalité d'application requise
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Liste les sources (ou comptes) de contacts enregistrés sur l’appareil.
Remarque : Cette fonction est utilisable uniquement à partir de Android 2.0.
Versions 18 et supérieures
Widget Android Cette fonction est désormais disponible en mode Widget Android.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 18
Widget Android Cette fonction est désormais disponible en mode Widget Android.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Versions 22 et supérieures
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Nouveauté 22
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Universal Windows 10 App Cette fonction est désormais disponible en mode Universal Windows 10 App.
Exemple
// Liste les comptes Google du téléphone
tabSource est un tableau de ContactSource = ContactListeSource()
SI PAS ErreurDétectée ALORS
        POUR TOUT UneSource DE tabSource
                SI UneSource..Type = "com.google" ALORS
                        // Traitement ...        
                FIN
        FIN
FIN
// Initialisation de la Zone Répétée ZR_Sources
// Liste les sources
gtabContactSource = ContactListeSource()

// Parcours des sources
POUR TOUT UneSource DE gtabContactSource
        ZoneRépétéeAjouteLigne(ZR_Sources, UneSource..Nom, DonneTypeSource(UneSource..Type))
FIN
Syntaxe
<Résultat> = ContactListeSource()
<Résultat> : Tableau de variables de type ContactSource
Tableau de variables de type ContactSource initialisé avec la liste des sources (ou comptes) de contacts enregistrés sur l’appareil.
En cas d'erreur, la variable ErreurDétectée est à Vrai. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
Remarques
Versions 22 et supérieures
Universal Windows 10 App

Fonctionnalité d'application requise

L’utilisation de cette fonction entraîne la déclaration d'une fonctionnalité d'application dans l'assistant de génération de l'application.
Fonctionnalité requise : Contacts
Cette fonctionnalité permet aux applications d'accéder aux contacts.
Nouveauté 22
Universal Windows 10 App

Fonctionnalité d'application requise

L’utilisation de cette fonction entraîne la déclaration d'une fonctionnalité d'application dans l'assistant de génération de l'application.
Fonctionnalité requise : Contacts
Cette fonctionnalité permet aux applications d'accéder aux contacts.
Universal Windows 10 App

Fonctionnalité d'application requise

L’utilisation de cette fonction entraîne la déclaration d'une fonctionnalité d'application dans l'assistant de génération de l'application.
Fonctionnalité requise : Contacts
Cette fonctionnalité permet aux applications d'accéder aux contacts.
Liste des exemples associés :
WM Gestion Contacts Exemples multiplateforme (WINDEV Mobile) : WM Gestion Contacts
[ + ] Cet exemple illustre la gestion de contacts pour Android et iOS.
Il permet de :
- lister les contacts du téléphone
- appeler les contacts
- envoyer des sms aux contacts
- ...
Version minimum requise
  • Version 17
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire