PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Présentation du champ
  • Notes
  • Description d'un champ ".NET 2.0 (WinForm)
  • Limitations
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation du champ
Le champ ".NET 2.0 (WinForm)" permet de gérer simplement les contrôles .NET au format WinForm (à partir de .NET 2.0).
Pour utiliser ce champ, nous vous conseillons fortement de vous reporter à la documentation de Microsoft.
Pour créer un champ de type ".NET 2.0 (WinForm)" :
  1. Sous l'éditeur de fenêtres, cliquez sur l'icône (ou sélectionnez l'option "Insertion .. Champ .. Champ NET 2.0 (WinForm")).Sous le volet "Création", dans le groupe "Autres champs", cliquez sur ".Net".
  2. Cliquez dans la fenêtre à la position où le champ doit être créé. Le champ apparaît en création.
Pour afficher les caractéristiques du champ, sélectionnez l'option "Description" dans le menu contextuel du champ.
Remarque : WINDEV propose également d'utiliser les champs de type DotNet utilisant le format WPF. Pour plus de détails, consultez Champ DotNet (WPF).
Notes

Description d'un champ ".NET 2.0 (WinForm)

Pour définir les caractéristiques du champ :
  1. Affichez la fenêtre de description du champ.
  2. Dans l'onglet "Général", sélectionnez l'assemblage utilisé et la classe associée. Le bouton "Ajouter des assemblages .NET dans le projet" permet d'intégrer les assemblages nécessaires. Il est possible d'utiliser :
    • Un assemblage DotNet personnel
    • Un assemblage DotNet fourni avec le framework DotNet.
Le champ peut ensuite être manipulé par programmation. Pour plus de détails, consultez Programmation d'un champ de type ".NET 2.0 (WinForm)".

Limitations

Les limitations du champ ".NET 2.0 (WinForm)" sont les suivantes :
  • Le framework DotNet 2.0 ou supérieur doit être installé sur le poste. Ce framework est inclus sous Vista et téléchargeable pour Windows XP (sur le site de Microsoft).
    La première utilisation d'un champ utilisant ce framework (champ Carrousel, champ Cube, champ ".NET 3.0, 4.0, ... (WPF)") demande le chargement de ce framework ce qui peut entraîner un délai (indépendant de notre volonté).
  • L'application ne peut être lancée depuis le réseau.
  • Le GFI est désactivé sur toutes les fenêtres contenant un champ ".NET 2.0 (WinForm)".
  • Ce champ ne fonctionne pas sous TSE.
  • Ce champ utilise la librairie wdxxxnet.dll. Cette librairie ne peut pas être renommée lors de la création de l'exécutable.
Version minimum requise
  • Version 16
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire