PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Exemple : Envoi d'un email en utilisant le protocole SMTP
  • Exemple : Envoi d'un email par l'intermédiaire de MS Exchange
  • Exemple : Envoi d'un email par l'intermédiaire de Pocket Outlook
  • Envoi d'email via un serveur SMTP Sécurisé
EmailEnvoieMessage (Exemple)
Exemple : Envoi d'un email en utilisant le protocole SMTP
Le code suivant permet d'envoyer un email en utilisant le protocole SMTP. Les caractéristiques du protocole SMTP ont été précisées grâce à la fonction EmailOuvreSession (adresse du serveur POP3, adresse du serveur SMTP, etc.).
SI EmailOuvreSession(USER, PASSWORD, "pop3.gmail.com", ...
"smtp.gmail.com") = Vrai ALORS
NomUser = USER
SINON
  NomUser = ""
  Erreur("Impossible d'établir la connexion")
FIN

// Initialise les composantes du mail
// L'expéditeur
Email.Expéditeur = "<user@pcsoft.fr>"
// Le destinataire
Email.Destinataire[1] = DESTINATAIRE
// Le nombre de destinataires
Email.NbDestinataire = 1
// Le sujet
Email.Sujet = SUJET
// Le corps du message
Email.Message = TEXTE
// Le nombre de pièces attachées
Email.NbAttache = 0

// Envoie le mail
SI EmailEnvoieMessage(NomUser) = Faux ALORS
Erreur()
FIN
Exemple : Envoi d'un email par l'intermédiaire de MS Exchange
Exemple : Envoi d'un email par l'intermédiaire de Pocket Outlook
WINDEV MobileWindows Mobile Le code suivant utilise Pocket Outlook pour envoyer un email. Un compte "Compte_Exemple" a été créé sous Pocket Outlook. Pour plus de détails sur la création des comptes, consultez la page d'aide Gérez les emails grâce à CEMAPI : Autres comptes.
IDEmail est un entier
IDEmail = EmailOuvreSession("Compte_Exemple")

// Initialisation des variables
Email.NbDestinataire = 1
Email.Destinataire[1] = "pcsoft@pcsoft.fr"
Email.NbAttache = 0
Email.Message = ""

// Envoie du message
EmailEnvoieMessage(IDEmail)
...
EmailFermeSession(IDEmail)
Envoi d'email via un serveur SMTP Sécurisé
// Envoi d'email via un serveur SMTP Sécurisé

// Session SMTP Sécurisée
gSessionSMTP est une EmailSessionSMTP
gSessionSMTP..AdresseServeur = "smtp.gmail.com"
gSessionSMTP..Nom = gsUser
gSessionSMTP..MotDePasse = gsPassword
gSessionSMTP..Port = 587
gSessionSMTP..Option = emailOptionSécuriséTLS

// Contenu de l'email    
UnCourriel est un Email
UnCourriel..AdresseExpéditeur = gsUser
UnCourriel..Destinataire[1] = "pcsoft@pcsoft.fr"
UnCourriel..Sujet = "Envoi d'un email depuis WINDEV."
UnCourriel..Message = "Envoi d'un message email depuis WINDEV."

// Envoi de l'email
SI EmailOuvreSession(gSessionSMTP) = Vrai ALORS
SI EmailEnvoieMessage(gSessionSMTP, UnCourriel) = Faux ALORS
Erreur("L'envoi de l'email a échoué.", ErreurInfo(errMessage))
FIN
SINON
Erreur("Impossible d'établir la connexion", ErreurInfo(errMessage))
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire